資料載入中

胡言亂語

Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 12288 bytes) in

今天在客戶的網站系統上發現了一個問題。
在上傳檔案時發生了一個錯誤:
Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 12288 bytes) in

錯誤的原因:
因為php頁面消耗的最大記憶體預設是為8M,如果檔案太大或圖片太大,在讀取的時候會發生上述提示錯誤。
解決方式,我直接在該處理PHP檔案裡加入以下設定:
ini_set("memory_limit","20M");

20M是可以依據自己的需求去設定。
又或者是修改.htaccess:
php_value memory_limit 20M


以上紀錄~

  • 客戶網站系統上傳檔案錯誤
  • PHP頁面最大記憶體設定
  • 檔案過大導致的錯誤
  • 修改.htaccess解決方案
  • 設定PHP記憶體限制的方法
https://innstory.com/story-FatalerrorAllowedmemorysizeof50331648bytesexhaustedtriedtoallocate12288bytesin-2741

上一篇
 使用htaccess關閉緩存

下一篇
直接在PHP重新命名帶有前綴的sessionname 

發表留言

作者簡介

離不開電腦的宅男


推薦閱讀

作者其他相關類別故事

使用JavaScript的split函式完成字串切割

使用JavaScript的s…

Mark Chang 7 年又 296 天 2K

使用JavaScript的split 函式可以用來切割字串。 根據設定的切割點執行切開的動作。 以下...

php定時執行任務ignore_user_abort 函式

php定時執行任務ignor…

Mark Chang 7 年又 33 天 3.7K

ignoreuserabort() 函式 最近剛好有一個專案需要定時執行任務功能,原本一開始想到的是...

在PHP中如何將NAN轉換為0

在PHP中如何將NAN轉換為…

Mark Chang 5 年又 279 天 1.2K

首先我會得到NAN是因為我有一個計算結果為0的值然後我讓他除以0,結果就得到了NAN 首先甚麼是N...